lab-4.1-report.txt

Yu Cheng (Jade)
ICS 351
Lab Report 4 part 1
October 12, 2008

[Exercise 1]
We connected the ethernet interfaces of the PCs and the routers.  We used the
following commands to configure the IP addresses and the interfaces on the PCs:

    on PC1: `ifconfig eth0 10.0.1.10/24`
    on PC2: `ifconfig eth0 10.0.2.10/24`
    on PC3: `ifconfig eth0 10.0.3.10/24`
    on PC4: `ifconfig eth0 10.0.4.10/24`

We used the following commands to turn on the RIP protocol and configure the IP
addresses and interfaces on the routers:

<Router 1>
    on PC1: `minicom`
    username: cisco
    password: cisco
    yourname# config t
    yourname(config)# no ip routing
    yourname(config)# ip routing
    yourname(config)# router rip
    yourname(config-router)# version 2
    yourname(config-router)# network 10.0.0.0
    yourname(config-router)# interface FastEthernet0/0
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.1.1 255.255.255.0
    yourname(config-if)# interface FastEthernet0/1
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.2.1 255.255.255.0
    yourname(config-if)# end
    yourname# clear ip route *

<Router 2>
    yourname(config)# router rip
    yourname(config-router)# version 2
    yourname(config-router)# network 10.0.0.0
    yourname(config-router)# interface FastEthernet0/0
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.2.2 255.255.255.0
    yourname(config-if)# interface FastEthernet0/1
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.3.2 255.255.255.0
    yourname(config-if)# end
    yourname# clear ip route *

<Router 3>
    yourname(config)# router rip
    yourname(config-router)# version 2
    yourname(config-router)# network 10.0.0.0
    yourname(config-router)# interface FastEthernet0/0
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.3.3 255.255.255.0
    yourname(config-if)# interface FastEthernet0/1
    yourname(config-if)# no shutdown
    yourname(config-if)# ip address 10.0.4.3 255.255.255.0
    yourname(config-if)# end
    yourname# clear ip route *

We used command `show ip route` to display the routing tables on every router to
ensure the configuration was correct.  We observed four entries in each routing
table. Since the RIP routing protocol was turned on, the routers exchanged
routing information with their directly connected neighbours.  When the routing
tables stablized, each router had information about all networks in the system.

We also issued ping commands from Router1 to both interfaces on Router2, both
interfaces on Router3, and from Router2 to both interfaces on Router3.  This is
to make sure the setup and configuration were correct.  The ping commands were
all successful.  The commands were:

    on Router1: `yourname# ping 10.0.3.2`
    on Router1: `yourname# ping 10.0.2.2`
    on Router1: `yourname# ping 10.0.3.3`
    on Router1: `yourname# ping 10.0.4.3`
    on Router2: `yourname# ping 10.0.3.3`
    on Router2: `yourname# ping 10.0.4.3`


[Exercise 2]
We added the directory /etc/rc.d/init.d to the search path of the shell on all
four PCs.  We were using the bash shell so the command of adding a directory is:

    on PC#: `export PATH=/etc/rc.d/init.d/:$PATH

We issued commands to start the zebra and the ripd processes on all four PCs.
We also connected to the ripd processes via Telnet.  The commands we used were:

    on PC#: `zebra start`
    on PC#: `ripd start`
    on PC#: `telnet localhost 2602`

After entering the password, the prompt symbol became "ripd#".  In order to
configure the hosts and set them to run RIP in passive mode, we used commands:

    on PC#: `ripd# config t`
    on PC#: `ripd(config)# router rip`
    on PC#: `ripd(config-router)# version 2`
    on PC#: `ripd(config-router)# network 10.0.0.0/8`
    on PC#: `ripd(config-router)# passive-interface eth0`
    on PC#: `ripd(config-router)# end`

We used command `show ip rip` to display the routing database of the RIP
protocol.  We issued this command several times until the routing databases were
stabilized.  We saved the output of this command on each PC as ex2-4pc1.txt,
ex2-4pc2.txt, ex2-4pc3.txt, and ex2-4pc4.txt.

<PC1 RIP routing database>
     Network            Next Hop         Metric From            Tag Time
C(i) 10.0.1.0/24        0.0.0.0               1 self              0
R(n) 10.0.2.0/24        10.0.1.1              2 10.0.1.1          0 02:53
R(n) 10.0.3.0/24        10.0.1.1              3 10.0.1.1          0 02:53
R(n) 10.0.4.0/24        10.0.1.1              4 10.0.1.1          0 02:53

<PC2 RIP routing database>
     Network            Next Hop         Metric From            Tag Time
R(n) 10.0.1.0/24        10.0.2.1              2 10.0.2.1          0 02:43
C(i) 10.0.2.0/24        0.0.0.0               1 self              0
R(n) 10.0.3.0/24        10.0.2.2              2 10.0.2.2          0 02:37
R(n) 10.0.4.0/24        10.0.2.2              3 10.0.2.2          0 02:37

<PC3 RIP routing database>
     Network            Next Hop         Metric From            Tag Time
R(n) 10.0.1.0/24        10.0.3.2              3 10.0.3.2          0 02:43
R(n) 10.0.2.0/24        10.0.3.2              2 10.0.3.2          0 02:43
C(i) 10.0.3.0/24        0.0.0.0               1 self              0
R(n) 10.0.4.0/24        10.0.3.3              2 10.0.3.3          0 02:46

<PC4 RIP routing database>
     Network            Next Hop         Metric From            Tag Time
R(s) 10.0.0.0/8         0.0.0.0               1 self              0
R(n) 10.0.1.0/24        10.0.4.3              4 10.0.4.3          0 02:56
R(n) 10.0.2.0/24        10.0.4.3              3 10.0.4.3          0 02:56
R(n) 10.0.3.0/24        10.0.4.3              2 10.0.4.3          0 02:56
C(i) 10.0.4.0/24        0.0.0.0               1 self              0
C(i) 10.4.0.0/24        0.0.0.0              16 self              0 01:09

I'm not sure why there is an entry in PC4 pointing to the network 10.4.0.0/24.

We issued command `netstat -rn` on all PCs, and we appended the output in
ex2-4pc1.txt, ex2-4pc2.txt, ex2-4pc3.txt, and ex2-4pc4.txt.

<PC1 routing table>
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.4.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
10.0.1.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.0.2.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
10.0.3.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

<PC2 routing table>
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.4.0        10.0.2.2        255.255.255.0   UG        0 0          0 eth0
10.0.1.0        10.0.2.1        255.255.255.0   UG        0 0          0 eth0
10.0.2.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.0.3.0        10.0.2.2        255.255.255.0   UG        0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

<PC3 routing table>
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.4.0        10.0.3.3        255.255.255.0   UG        0 0          0 eth0
10.0.1.0        10.0.3.2        255.255.255.0   UG        0 0          0 eth0
10.0.2.0        10.0.3.2        255.255.255.0   UG        0 0          0 eth0
10.0.3.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

<PC4 routing table>
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.4.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.0.1.0        10.0.4.3        255.255.255.0   UG        0 0          0 eth0
10.0.2.0        10.0.4.3        255.255.255.0   UG        0 0          0 eth0
10.0.3.0        10.0.4.3        255.255.255.0   UG        0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

We issued some ping commands to further test the connection.  We then issued
a traceroute command from PC1 to PC4 to display the routes.  We saved the ouput
as file ex2-7.txt.

    [root@PC1 ~]# traceroute 10.0.4.10
    traceroute to 10.0.4.10 (10.0.4.10), 30 hops max, 40 byte packets
     1  10.0.1.1 (10.0.1.1)  1.447 ms  1.520 ms  1.636 ms
     2  10.0.2.2 (10.0.2.2)  1.056 ms  0.996 ms  1.113 ms
     3  10.0.3.3 (10.0.3.3)  0.938 ms  1.353 ms  1.453 ms
     4  10.0.4.10 (10.0.4.10)  1.313 ms  1.159 ms  1.072 ms

While issuing the traceroute command, we also started wireshark on all four PCs
to capture the network traffic.  We saved the detailed contents of the traffic
as ex2-8pc1.txt, ex2-8.txtpc2, ex2-8.txtpc3, and ex2-8.txtpc4.  We should've set
a display or capture filter.  Since we didn't do that, I manually deleted all
other packets and left only RIP packets.

Question 8-a:
The destination IP address of all RIP packets is 224.0.0.9.  This is the RIP
Version 2 group address.  It is used to send RIP routing information to all
RIPv2 routers on a network segment.  The IPv4 addresses ranging from 224.0.0.0
to 224.0.0.255 are designated for multicasting on the local LAN only.

Question 8-b:
The Routers in the lab setup are in active mode.  They advertise their routes
(reachability information) to others.

PC1 did not receive RIP packets sent by Router3.  The communication of the RIP
protocol is restricted among directly connected entities.  The information about
Router3 and the networks associated with Router3 was passed to PC1 through
Router1.

Question 8-c:
By investigating the routing information protocol section, we observed only
RIPv2 Response packets.

PCs were in the passive mode.  They listened and updated their routes based on
advertisements but did not advertise.  They were used as hosts but not gateways.
The response type of the messages were therefore used to inform the network
entities to update their routing entires based on the up-to-date information.

Question 8-d:
RIP messages for each routing table entry contained 20 bytes.  We learned about
this number by highlighting the routing protocol information bullet and counting
the bytes in the hexadecimal output.

The information transmitted included IP addresses, Metrics, Next Hop, and
Netmask.

Question 1:
    Routing Information Protocol
        Command: Response (2)
        Version: RIPv2 (2)
        Routing Domain: 0
        IP Address: 10.0.2.0, Metric: 1
            Address Family: IP (2)
            Route Tag: 0
            IP Address: 10.0.2.0 (10.0.2.0)
            Netmask: 255.255.255.0 (255.255.255.0)
            Next Hop: 0.0.0.0 (0.0.0.0)
            Metric: 1
        IP Address: 10.0.3.0, Metric: 2
            Address Family: IP (2)
            Route Tag: 0
            IP Address: 10.0.3.0 (10.0.3.0)
            Netmask: 255.255.255.0 (255.255.255.0)
            Next Hop: 0.0.0.0 (0.0.0.0)
            Metric: 2
        IP Address: 10.0.4.0, Metric: 3
            Address Family: IP (2)
            Route Tag: 0
            IP Address: 10.0.4.0 (10.0.4.0)
            Netmask: 255.255.255.0 (255.255.255.0)
            Next Hop: 0.0.0.0 (0.0.0.0)
            Metric: 3

"Command" indicates the type of the message was a RIP response message.  The
protocol type was RIP version 2.  In the RIP message, there was information
about three different networks: 10.0.2.0, 10.0.3.0, and 10.0.4.0.  The
information also included their IP addresses, Metrics, Next Hops, and Netmasks.

Question 2:
<PC1 RIP routing database>
     Network            Next Hop         Metric From            Tag Time
C(i) 10.0.1.0/24        0.0.0.0               1 self              0
R(n) 10.0.2.0/24        10.0.1.1              2 10.0.1.1          0 02:53
R(n) 10.0.3.0/24        10.0.1.1              3 10.0.1.1          0 02:53
R(n) 10.0.4.0/24        10.0.1.1              4 10.0.1.1          0 02:53

<PC1 routing table>
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.4.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
10.0.1.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.0.2.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
10.0.3.0        10.0.1.1        255.255.255.0   UG        0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

The output of command `show ip rip` contains information about the Metirc.  The
output of command `netstat -rn` contains information about netmask and
interface.  The routing table contained information of all interfaces that were
up.  The rip table contained information that exchanged using RIP protocol.  It
also showed the time when the entries were created.
Valid HTML 4.01 Valid CSS